Skip to main content
VulnerabilityPublished Updated

CVE-2025-37756: linux-raspi vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare

Not known to be exploited : upgrade to 6.8.0-1040.44 soon.

Data as of 31 Oct 2026, 01:35 UTC

Severity
High

Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA

Patch
Available – fixed in 6.8.0-1040.44

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade the Ubuntu linux-raspi package to 6.8.0-1040.44.

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSlinux-raspipkg:deb/ubuntu/linux-raspi?arch=source&distro=nobleOther threatsAffected
  • <6.8.0-1040.44
Fixed in
  • 6.8.0-1040.44

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in Linux kernel version 6.8.0-1040.44. Users should update their systems to this version and reboot to apply the fixes. Due to an ABI change, recompilation and reinstallation of any third-party kernel modules are necessary after the update. Following the vendor's update instructions will mitigate the vulnerabilities.

Description

Multiple security vulnerabilities were discovered in the Linux kernel for Raspberry Pi systems affecting several subsystems including Ext4 file system, packet sockets, network traffic control, TLS protocol, VMware vSockets driver, and XFRM subsystem. These flaws could potentially allow an attacker to compromise the system. A fixed kernel version 6.8.0-1040.44 has been released to address these issues. Users are advised to update and reboot their systems. Due to an ABI change, third-party kernel modules may need recompilation.

References

Community reviews

Loading reviews…