Skip to main content
VulnerabilityPublished Updated

CVE-2025-38561: linux-realtime, linux-realtime-6.8, linux-raspi-realtime vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare

Mentioned vulnerabilities

Not known to be exploited · fixed in 6.8.1-1040.41~22.04.1 : patch Linux kernel soon.

Data as of 3 Nov 2026, 17:43 UTC

Severity
High

Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA

Patch
Available – fixed in 6.8.1-1040.41~22.04.1, 6.8.0-2036.37, 6.8.1-1040.41

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Feb 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade the Ubuntu to 6.8.1-1040.41~22.04.1 (linux-realtime-6.8 package) or 6.8.0-2036.37 (linux-raspi-realtime package) or 6.8.1-1040.41 (linux-realtime package).

Affected software

ProductAffectedFixed in
Ubuntu Pro Realtime 24.04 LTSlinux-raspi-realtimepkg:deb/ubuntu/linux-raspi-realtime?arch=source&distro=realtime/nobleOther threatsAffected
  • <6.8.0-2036.37
Fixed in
  • 6.8.0-2036.37
Ubuntu Pro Realtime 24.04 LTSlinux-realtimepkg:deb/ubuntu/linux-realtime?arch=source&distro=realtime/nobleOther threatsAffected
  • <6.8.1-1040.41
Fixed in
  • 6.8.1-1040.41
Ubuntu Pro Realtime 22.04 LTSlinux-realtime-6.8pkg:deb/ubuntu/linux-realtime-6.8?arch=source&distro=realtime/jammyOther threatsAffected
  • <6.8.1-1040.41~22.04.1
Fixed in
  • 6.8.1-1040.41~22.04.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied promptly. Users should update to the fixed package versions (6.8.1-1040.41~22.04.1, 6.8.0-2036.37, or 6.8.1-1040.41) as provided by Ubuntu security notices (USN-8015-2). After updating, a system reboot is required to activate the fixes. Due to an ABI change, all third-party kernel modules must be recompiled and reinstalled to ensure compatibility. Standard system upgrades will handle this automatically unless kernel metapackages have been manually removed.

Description

Multiple security vulnerabilities were identified in the Linux kernel's cryptographic API, SMB network file system, and io_uring subsystem. These flaws could potentially allow an attacker to compromise affected systems. The issues affect various versions of the linux-realtime-6.8 kernel and related packages. Official patches addressing these vulnerabilities have been released and are available through Ubuntu security updates. Users must update and reboot their systems to apply the fixes. Due to ABI changes, recompilation of third-party kernel modules is required after updating.

References

Community reviews

Loading reviews…