CVE-2025-37838: linux-realtime, linux-realtime-6.8 vulnerabilities
Affects Linux kernelSource GCVE Database
Not known to be exploited · fixed in 6.8.1-1037.38~22.04.1 : patch Linux kernel soon.
Data as of 31 Oct 2026, 01:11 UTC
Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA
- Patch
- Available – fixed in 6.8.1-1037.38~22.04.1, 6.8.1-1037.38
Exploitation evidence
Disclosed: evidence found.
CVE published 7 Nov 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade the Ubuntu to 6.8.1-1037.38~22.04.1 (linux-realtime-6.8 package) or 6.8.1-1037.38 (linux-realtime package).
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu Pro Realtime 24.04 LTSlinux-realtimepkg:deb/ubuntu/linux-realtime?arch=source&distro=realtime/nobleOther threats | Affected
| Fixed in
|
Ubuntu Pro Realtime 22.04 LTSlinux-realtime-6.8pkg:deb/ubuntu/linux-realtime-6.8?arch=source&distro=realtime/jammyOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied immediately by updating to linux-image-realtime-6.8.1-1037.38 or later versions as provided by Ubuntu security notices USN-7861-2. After updating, a system reboot is required to activate the fixes. Due to an ABI change, all third-party kernel modules must be recompiled and reinstalled. Follow the vendor's update instructions carefully to ensure full remediation.
Description
Multiple security vulnerabilities were discovered in the Linux kernel real-time 6.8 series, including a flaw known as VMSCAPE that involves insufficient branch predictor isolation between a guest VM and a userspace hypervisor on certain processors. This flaw could allow an attacker in a guest VM to potentially expose sensitive information from the host OS. Additional issues affect the HSI, Bluetooth, and Timer subsystems. These vulnerabilities could be exploited to compromise the system. Fixes have been released in version 6.8.1-1037.38 and its variants, and a system reboot is required after updating.