Skip to main content
VulnerabilityPublished Updated

CVE-2025-37756: linux-realtime, linux-realtime-6.8 vulnerabilities

Affects Linux kernelSource GCVE Database

0
Compare

Not known to be exploited · fixed in 6.8.1-1035.36~22.04.1 : patch Linux kernel soon.

Data as of 31 Oct 2026, 01:29 UTC

Severity
High

Rated High by Threat Radar's AI analysis · No CVSS score from NVD or the CNA

Patch
Available – fixed in 6.8.1-1035.36~22.04.1, 6.8.1-1035.36

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade the Ubuntu to 6.8.1-1035.36~22.04.1 (linux-realtime-6.8 package) or 6.8.1-1035.36 (linux-realtime package).

Affected software

ProductAffectedFixed in
Ubuntu Pro Realtime 24.04 LTSlinux-realtimepkg:deb/ubuntu/linux-realtime?arch=source&distro=realtime/nobleOther threatsAffected
  • <6.8.1-1035.36
Fixed in
  • 6.8.1-1035.36
Ubuntu Pro Realtime 22.04 LTSlinux-realtime-6.8pkg:deb/ubuntu/linux-realtime-6.8?arch=source&distro=realtime/jammyOther threatsAffected
  • <6.8.1-1035.36~22.04.1
Fixed in
  • 6.8.1-1035.36~22.04.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches by upgrading to linux-image-6.8.1-1035.36 or linux-image-6.8.1-1035.36~22.04.1 as provided by the Ubuntu security notice USN-7799-1. After updating, reboot the system to ensure all changes take effect. Due to an ABI change, recompile and reinstall any third-party kernel modules. Standard system upgrades will handle this automatically unless kernel metapackages have been manually removed.

Description

Multiple security vulnerabilities were identified in the Linux kernel real-time version 6.8, affecting several subsystems including Ext4, packet sockets, network traffic control, TLS protocol, VMware vSockets driver, and XFRM. These flaws could potentially allow an attacker to compromise the system. Fixes have been released in versions 6.8.1-1035.36 and 6.8.1-1035.36~22.04.1. Users are advised to update and reboot their systems to apply these patches. Due to ABI changes, recompilation of third-party kernel modules may be required.

References

Community reviews

Loading reviews…