Skip to main content
VulnerabilityPublished Updated

CVE-2025-13465: Lodash Has Prototype Pollution Vulnerability

Affects lodashSource GCVE Database

0
Compare

Not known to be exploited · CVSS 6.5 Medium : upgrade to 4.17.23 when convenient.

Data as of 4 Nov 2026, 04:28 UTC

CVSS 3.1 base score
6.5Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.17.23, 4.18.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Jan 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Upgrade lodash and lodash-amd and lodash-es to 4.17.23; lodash.omit and lodash.unset to 4.18.0.

Affected software

ProductAffectedFixed in
npmlodashAffected
  • >=4.0.0 <4.17.23
Fixed in
  • 4.17.23
npmlodash-amdAffected
  • >=4.0.0 <4.17.23
Fixed in
  • 4.17.23
npmlodash-esAffected
  • >=4.0.0 <4.17.23
Fixed in
  • 4.17.23
npmlodash.omitAffected
  • >=4.0.0 <4.18.0
Fixed in
  • 4.18.0
npmlodash.unsetAffected
  • >=4.0.0 <4.18.0
Fixed in
  • 4.18.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Lodash to version 4.17.23 or later for lodash, lodash-es, and lodash-amd packages, and to version 4.18.0 or later for lodash.unset and lodash.omit packages. No other workarounds are available. Applying these patches fully mitigates the vulnerability.

Description

Lodash versions prior to 4.17.23 and 4.18.0 have a prototype pollution vulnerability in the _.unset, _.omit, and _.pullAt functions. This flaw allows attackers to delete methods from global prototypes by passing crafted paths. The vulnerability permits deletion of properties but does not allow overwriting their original behavior. Patched versions are available starting from 4.17.23 and 4.18.0 depending on the package.

References

Community reviews

Loading reviews…