Skip to main content
VulnerabilityPublished Updated

CVE-2026-44681: Mcp atlassian · Authlib OIDC Implicit/Hybrid Authorization Vulnerable to Open Redirect

Affects mcp-atlassianSource GCVE Database

0
Compare

Not known to be exploited · CVSS 6.1 Medium : upgrade to 0.21.1_4 when convenient.

Data as of 30 Oct 2026, 08:31 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.21.1_4
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade mcp-atlassian to 0.21.1_4.

Affected software

ProductAffectedFixed in
Homebrewmcp-atlassianpkg:brew/mcp-atlassianOther threatsAffected
  • >=0.11.11 <0.21.1_4
Fixed in
  • 0.21.1_4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in Authlib version 0.21.1_4 that fixes this open redirect vulnerability. Users should upgrade to version 0.21.1_4 or later. Until patched, avoid enabling the OpenIDImplicitGrant or OpenIDHybridGrant flows if possible. No other mitigations are indicated by the vendor advisory.

Description

Authlib's OpenID Connect Implicit and Hybrid authorization endpoints contain an unauthenticated open redirect vulnerability. An attacker can craft an authorization request omitting the 'openid' scope, causing the server to redirect users to an attacker-controlled URL. This occurs because the scope validation error redirects using an unvalidated redirect_uri parameter. The flaw affects Authlib versions from 0.11.11 up to but not including 0.21.1_4 and has been fixed in 0.21.1_4. The vulnerability enables phishing and credential harvesting by leveraging the trusted authorization server's domain in the redirect.

References

Community reviews

Loading reviews…