CVE-2026-28490: Mcp atlassian · Authlib Vulnerable to JWE RSA1_5 Bleichenbacher Padding Oracle
Affects mcp-atlassianSource GCVE Database
Not known to be exploited · CVSS 8.3 High : upgrade to 0.21.0 soon.
Data as of 30 Oct 2026, 08:31 UTC
- Patch
- Available – fixed in 0.21.0
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade mcp-atlassian to 0.21.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewmcp-atlassianpkg:brew/mcp-atlassianOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in Authlib version 0.21.0 that eliminates the exception oracle by removing the length check exception and restoring the Bleichenbacher mitigation behavior. Users should upgrade to Authlib 0.21.0 or later to remediate this vulnerability. No additional configuration is required once patched. Until patched, applications should consider disabling RSA1_5 or applying custom mitigations if feasible.
Description
A cryptographic padding oracle vulnerability exists in the Authlib Python library's implementation of the JSON Web Encryption (JWE) RSA1_5 key management algorithm. Authlib disables the Bleichenbacher mitigation implemented by the underlying cryptography library by raising a distinct exception on invalid padding, creating a reliable exception oracle. This vulnerability is active by default in Authlib versions before 0.21.0 and can be exploited via distinguishable error responses in common Python web frameworks. A fix is available in Authlib version 0.21.0.
References
- github.com/authlib/authlib/security/advisories/GHSA-7432-952r-cw78 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-28490 (opens in a new tab)
- github.com/authlib/authlib/commit/48b345f29f6c459f11c6a40162b6c0b742ef2e22 (opens in a new tab)
- github.com/authlib/authlib (opens in a new tab)
- github.com/authlib/authlib/releases/tag/v1.6.9 (opens in a new tab)