Skip to main content
VulnerabilityPublished Updated

CVE-2025-64340: Mcp atlassian · FastMCP has a Command Injection vulnerability - Gemini CLI

Affects mcp-atlassianSource GCVE Database

0
Compare
Authoritative record:CVE-2025-64340· Medium 6.7

Not known to be exploited · CVSS 6.7 Medium : upgrade to 0.23.0 when convenient.

Data as of 30 Oct 2026, 08:44 UTC

CVSS 3.1 base score
6.7Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.23.0
CVSS:3.1/AV:L/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Apr 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade mcp-atlassian to 0.23.0.

Affected software

ProductAffectedFixed in
Homebrewmcp-atlassianpkg:brew/mcp-atlassianOther threatsAffected
  • >=0.11.9 <0.23.0
Fixed in
  • 0.23.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patch by upgrading FastMCP to version 0.23.0 or later, which includes validation to reject server names containing shell metacharacters. Users should avoid using untrusted server names with shell metacharacters on Windows until patched. No additional mitigation is required as the fix addresses the root cause.

Description

A command injection vulnerability exists in FastMCP when installing the claude-code or gemini-cli tools on Windows. Server names containing shell metacharacters such as '&' can cause arbitrary command execution due to how Windows .cmd wrappers are invoked via cmd.exe. This affects FastMCP versions from 0.11.9 up to but not including 0.23.0. The issue does not affect macOS or Linux, nor config-file-based install targets. The vulnerability is patched in version 0.23.0 by validating server names to reject shell metacharacters.

References

Community reviews

Loading reviews…