CVE-2026-32871: Mcp atlassian · FastMCP OpenAPI Provider has an SSRF & Path Traversal Vulnerability
Affects mcp-atlassianSource GCVE Database
Not known to be exploited · CVSS 10.0 Critical : upgrade to 0.23.0 as a priority.
Data as of 30 Oct 2026, 08:31 UTC
- Patch
- Available – fixed in 0.23.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:HExploitation evidence
Disclosed: evidence found.
CVE published 2 Apr 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade mcp-atlassian to 0.23.0.
Patches and advisories
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewmcp-atlassianpkg:brew/mcp-atlassianOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in FastMCP version 0.23.0 that properly URL-encodes all path parameter values before substitution, preventing traversal sequences from being interpreted. Users should upgrade to version 0.23.0 or later to remediate this vulnerability. No additional mitigation steps are required beyond applying the official patch.
Description
FastMCP OpenAPI Provider contains a critical vulnerability in its URL construction logic that allows authenticated attackers to perform server-side request forgery (SSRF) and path traversal. The vulnerability arises because path parameters are substituted into URL templates without URL encoding, enabling attackers to inject traversal sequences like '../' to escape intended API paths. This leads to unauthorized access to internal backend endpoints with the MCP provider's authentication context.
References
- github.com/PrefectHQ/fastmcp/security/advisories/GHSA-vv7q-7jx5-f767 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-32871 (opens in a new tab)
- github.com/PrefectHQ/fastmcp/pull/3507 (opens in a new tab)
- github.com/PrefectHQ/fastmcp/commit/40bdfb6b1de0ce30609ee9ba5bb95ecd04a9fb71 (opens in a new tab)
- access.redhat.com/errata/RHSA-2026:36350 (opens in a new tab)
- access.redhat.com/security/cve/CVE-2026-32871 (opens in a new tab)
- bugzilla.redhat.com/show_bug.cgi?id=2454434 (opens in a new tab)
- github.com/PrefectHQ/fastmcp (opens in a new tab)
- github.com/PrefectHQ/fastmcp/releases/tag/v3.2.0 (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/fastmcp/PYSEC-2026-338.yaml (opens in a new tab)
- pypi.org/project/fastmcp (opens in a new tab)
- security.access.redhat.com/data/csaf/v2/vex/2026/cve-2026-32871.json (opens in a new tab)