Skip to main content
VulnerabilityPublished Updated

CVE-2025-62800: Mcp atlassian · FastMCP vulnerable to reflected XSS in client's callback page

Affects mcp-atlassianSource GCVE Database

0
Compare
Authoritative record:CVE-2025-62800· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium : upgrade to 0.11.11 when convenient.

Data as of 30 Oct 2026, 08:44 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.11.11
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade mcp-atlassian to 0.11.11.

Affected software

ProductAffectedFixed in
Homebrewmcp-atlassianpkg:brew/mcp-atlassianOther threatsAffected
  • >=0.11.9 <0.11.11
Fixed in
  • 0.11.11

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in FastMCP version 0.11.11 that properly escapes or sanitizes user-controlled input in the OAuth callback page. Users should upgrade to version 0.11.11 or later to remediate this vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

A reflected Cross-Site Scripting (XSS) vulnerability exists in the FastMCP OAuth client's callback page. User-controlled input parameters, such as 'error', are embedded into the callback page without proper escaping or sanitization, allowing arbitrary JavaScript execution in the callback server's origin. This affects FastMCP versions from 0.11.9 up to but not including 0.11.11. The vulnerability has a CVSS 4.0 base score of 5.3 (medium severity).

References

Community reviews

Loading reviews…