Skip to main content
CVE-2026-122133VulnerabilityPublished

Mistral Vibe before 2.25.5 on Windows contains an untrusted search path vulnerability that allows attackers to execute

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-122133· High 8.6

Not known to be exploited · CVSS 8.6 High : upgrade to 2.25.5 soon.

Data as of 4 Nov 2026, 22:52 UTC

CVSS 4.0 base score
8.6High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.6
CNA (VulnCheck)CVSS 3.18.8
Patch
Available – fixed in 2.25.5
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade mistral-vibe to 2.25.5.

Affected software

ProductAffectedFixed in
mistralaimistral-vibeAffected
  • <2.25.5
Fixed in
  • 2.25.5
PyPImistral-vibepkg:pypi/mistral-vibeOther threatsAffected
  • <2.25.5
Fixed in
  • 2.25.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Mistral Vibe version 2.25.5 and later. Users should upgrade to version 2.25.5 or newer to remediate this vulnerability. No additional mitigations are specified in the provided data.

Description

Mistral Vibe versions before 2.25.5 on Windows are affected by an untrusted search path vulnerability. This flaw allows attackers to execute arbitrary code by placing a malicious git.exe file in a repository root. When a user opens a crafted repository, components SessionLogger and ProjectContextProvider run the malicious git.exe at session start before any trust prompt appears. The vulnerability has a high severity with a CVSS score of 8.8.

References

Community reviews

Loading reviews…