Skip to main content
CVE-2026-124028VulnerabilityPublished

mistral.rs before 0.9.5 contains a delimiter injection vulnerability in mistralrs-core that allows attackers to inject

Affects mistral.rsSource GCVE Database

0
Compare
Authoritative record:CVE-2026-124028· Low 2.3

Not known to be exploited · CVSS 2.3 Low : upgrade to 0.9.5 when convenient.

Data as of 6 Nov 2026, 22:42 UTC

CVSS 4.0 base score
2.3Low
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.02.3
CNA (VulnCheck)CVSS 3.14.2
Affects
mistral.rs before 0.9.5
Patch
Available – fixed in 0.9.5
CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 6 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 6 Nov 2026.

What to do

Upgrade github/EricLBuehler/mistral.rs to 0.9.5.

Affected software

ProductAffectedFixed in
crates.iogithub/EricLBuehler/mistral.rspkg:cargo/github/EricLBuehler/mistral.rsOther threatsAffected
  • <0.9.5
Fixed in
  • 0.9.5

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade mistral.rs to version 0.9.5 or later, where this delimiter injection vulnerability is fixed. No other mitigation steps are indicated or necessary once the update is applied.

Description

A delimiter injection vulnerability exists in mistral.rs versions before 0.9.5 within the mistralrs-core component. This flaw allows attackers who can control input documents, web pages, or tool outputs to inject tool calls by embedding delimiter strings such as </tool_call>. This causes parsers like qwen-xml, gemma4, or reasoning parsers to execute additional tool calls with attacker-supplied arguments. The vulnerability is fixed in version 0.9.5.

References

Community reviews

Loading reviews…