MONAI from 1.2.0 before 1.6.1 contains a remote code execution vulnerability in ConfigWorkflow.__init__, which passes
Affects monaiSource GCVE Database
Not known to be exploited · CVSS 8.6 High · fixed in 1.6.1 : patch monai soon.
Data as of 28 Oct 2026, 22:14 UTC
- Patch
- Available – fixed in 1.6.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
PyPImonaipkg:pypi/monaiOther threats | Affected– | Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fixed version of MONAI is available starting from version 1.6.1. Users should upgrade to version 1.6.1 or later to remediate this vulnerability. No other mitigation or temporary workaround is indicated in the available data.
Description
MONAI versions from 1.2.0 up to but not including 1.6.1 contain a remote code execution vulnerability in the ConfigWorkflow.__init__ method. This vulnerability arises because the method passes a bundle's configs/logging.conf file to logging.config.fileConfig, which uses eval() on handler class and args fields. An attacker can exploit this by publishing a malicious bundle with a crafted logging.conf that executes arbitrary Python code when the victim loads or runs the bundle.