CVE-2026-104874: Reference leak in CIMultiDict/MultiDict items-view union and subtraction
Affects lexiconSource GCVE Database
Not known to be exploited · CVSS 5.3 Medium : upgrade to 3.25.2_4 when convenient.
Data as of 30 Oct 2026, 07:44 UTC
- Patch
- Available – fixed in 3.25.2_4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 2 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade lexicon to 3.25.2_4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewlexiconpkg:brew/lexiconOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in version 3.25.2_4 that fixes the reference leak. Users should upgrade to this fixed version or later to remediate the vulnerability. Since the issue is a memory leak triggered by specific set operations, upgrading the library is the recommended and effective mitigation. No other vendor advisories indicate alternative mitigations or that the issue is already mitigated.
Description
CVE-2026-104874 is a reference leak vulnerability in the items-view union and subtraction operators of the aio-libs/multidict Python library versions 6.7.0 through 6.9.0. The flaw causes unbounded memory growth by leaking key-identity and value objects during certain set operations on dictionary views. This leak occurs because new references are created but never released in specific code paths. The vulnerability can be triggered remotely by supplying large HTTP headers or query strings to servers using this library, causing memory exhaustion until the process is terminated.
References
- github.com/aio-libs/multidict/security/advisories/GHSA-54p9-h82j-f925 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-104874 (opens in a new tab)
- github.com/aio-libs/multidict/commit/350b4a07bf8ff851b6d7544e81b1c748bdc74c40 (opens in a new tab)
- github.com/aio-libs/multidict (opens in a new tab)
- github.com/aio-libs/multidict/releases/tag/v6.9.1 (opens in a new tab)