Skip to main content
VulnerabilityPublished

CVE-2026-114038: multipath-tools security update

Affects multipath-toolsSource GCVE Database

0
Compare
Authoritative record:CVE-2026-114038· Medium 5.1

Not known to be exploited · CVSS 5.1 Medium : upgrade to 0.9.5-22.oe2403sp3 when convenient.

Data as of 4 Nov 2026, 16:48 UTC

CVSS 3.1 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (redhat)CVSS 3.15.1
Patch
Available – fixed in 0.9.5-22.oe2403sp3
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade multipath-tools to 0.9.5-22.oe2403sp3.

Affected software

ProductAffectedFixed in
openEuler 24.03-LTS-SP3multipath-toolspkg:rpm/openEuler/multipath-tools&distro=openEuler-24.03-LTS-SP3Other threatsAffected
  • <0.9.5-22.oe2403sp3
Fixed in
  • 0.9.5-22.oe2403sp3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade multipath-tools to version 0.9.5-22.oe2403sp3 or later, where this vulnerability is fixed. No other mitigation is indicated or required.

Description

A vulnerability in multipath-tools (device-mapper-multipath) allows a local user to trigger an out-of-bounds read by sending a specially crafted command with a format string ending in a trailing percent character to the multipath daemon. This can lead to information disclosure or cause the daemon to crash, resulting in a denial of service. The issue affects versions prior to 0.9.5-22.oe2403sp3 and has been assigned CVE-2026-114038. A fix is available in version 0.9.5-22.oe2403sp3.

References

Community reviews

Loading reviews…