Mycli: setuptools has a path traversal vulnerability in PackageIndex.download that leads to Arbitrary File Write
Affects mycliSource GCVE Database
Public exploit available · CVSS 8.7 High : upgrade to 2.13.1 as a priority.
Data as of 30 Oct 2026, 08:45 UTC
- Patch
- Available – fixed in 2.13.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade mycli to 2.13.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewmyclipkg:brew/mycliOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied. The vulnerability is fixed in mycli version 2.13.1 and setuptools version 78.1.1. Users should upgrade to these versions or later to remediate the issue. No additional mitigations are specified by the vendor advisory.
Description
A path traversal vulnerability in setuptools' PackageIndex.download function allows an attacker to write files arbitrarily on the filesystem. This occurs due to insufficient sanitization of URL-derived filenames, enabling os.path.join to be bypassed. The vulnerability was fixed in setuptools version 78.1.1. Exploitation could lead to arbitrary file write with the permissions of the running process, potentially escalating to remote code execution depending on context. The affected product mycli is vulnerable in versions prior to 2.13.1, where the issue has been patched.
References
- github.com/pypa/setuptools/security/advisories/GHSA-5rjg-fvgr-3xxf (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2025-47273 (opens in a new tab)
- github.com/pypa/setuptools/issues/4946 (opens in a new tab)
- github.com/pypa/setuptools/commit/250a6d17978f9f6ac3ac887091f2d32886fbbb0b (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/setuptools/PYSEC-2025-49.yaml (opens in a new tab)
- github.com/pypa/setuptools (opens in a new tab)
- github.com/pypa/setuptools/blob/6ead555c5fb29bc57fe6105b1bffc163f56fd558/setuptools/package_index.py (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/05/msg00035.html (opens in a new tab)