Skip to main content
VulnerabilityPublished Updated

CVE-2024-6345: Mycli · setuptools vulnerable to Command Injection via package URL

Affects mycliSource GCVE Database

0
Compare
Authoritative record:CVE-2024-6345· High 8.8

Not known to be exploited · CVSS 8.8 High : upgrade to 2.13.1 soon.

Data as of 30 Oct 2026, 08:46 UTC

CVSS 3.0 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.13.1
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Jul 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade mycli to 2.13.1.

Affected software

ProductAffectedFixed in
Homebrewmyclipkg:brew/mycliOther threatsAffected
  • <2.13.1
Fixed in
  • 2.13.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and the issue is fixed in mycli version 2.13.1, which includes setuptools 70.0. Users should upgrade to mycli 2.13.1 or later to remediate this vulnerability. No additional mitigations are specified or required beyond applying the official fix.

Description

CVE-2024-6345 is a high-severity vulnerability in the setuptools package_index module used by mycli versions prior to 2.13.1. It allows remote code execution via command injection through unsafe handling of package URLs in download functions. The flaw is fixed in mycli version 2.13.1.

References

Community reviews

Loading reviews…