n8n before 1.123.85, 2.43.5, and 2.44.1 contains an authorization bypass vulnerability that allows member users to use
Affects n8nSource GCVE Database
Not known to be exploited · CVSS 5.1 Medium · fixed in 2.44.1 : update n8n when convenient.
Data as of 28 Oct 2026, 22:26 UTC
- Patch
- Available – fixed in 2.44.1, 2.43.5, 1.123.85
CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:H/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade n8n-io/n8n to 2.44.1, 2.43.5 or 1.123.85.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubn8n-io/n8npkg:github/n8n-io/n8nOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in n8n versions 1.123.85, 2.43.5, and 2.44.1. Users should upgrade to these or later versions to remediate the vulnerability. No additional mitigation steps are indicated in the provided data.
Description
n8n versions prior to 1.123.85, 2.43.5, and 2.44.1 contain an authorization bypass vulnerability. This flaw allows member users to access credentials they should not have permission to use by omitting default node parameters in workflows. Exploitation enables attackers to save and execute workflows that bypass pre-execution credential checks, resulting in decrypted credential values being sent to destinations controlled by the attacker.