Skip to main content
CVE-2026-118640VulnerabilityPublished

n8n before 1.123.85, 2.43.5, and 2.44.1 contains an authorization bypass vulnerability in Chat Hub that allows

Affects n8nSource GCVE Database

0
Authoritative record:CVE-2026-118640· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium · fixed in 2.44.1 : update n8n when convenient.

Data as of 28 Oct 2026, 22:27 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Affects
n8n before 1.123.85
Patch
Available – fixed in 2.44.1, 2.43.5, 1.123.85
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade n8n to 2.44.1, 2.43.5 or 1.123.85.

Affected software

ProductAffectedFixed in
npmn8npkg:npm/n8nOther threatsAffected
  • <1.123.85
  • <2.43.5
  • <2.44.1
Fixed in
  • 1.123.85
  • 2.43.5
  • 2.44.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

The vulnerability affects n8n versions before 1.123.85, 2.43.5, and 2.44.1. Users should upgrade to at least these versions where the issue is fixed. No vendor advisory or patch links were provided in the input, so confirm patch availability from official n8n sources before applying updates. Since this is not a cloud service, remediation requires user action to update affected installations.

Description

An authorization bypass vulnerability exists in n8n versions before 1.123.85, 2.43.5, and 2.44.1 within the Chat Hub component. This flaw allows users with the global:chatUser role, who normally have limited chat-only permissions, to register restricted tool types and execute sandboxed code, access permitted files, and utilize instance workflows, Data Tables, and agents. The vulnerability has a medium severity rating with a CVSS score of 5.4.

References

Community reviews

Loading reviews…