n8n before 1.123.85, 2.43.5, and 2.44.1 contains a credential guard bypass vulnerability that allows editors of shared
Affects n8nSource GCVE Database
Not known to be exploited · CVSS 5.1 Medium · fixed in 2.44.1 : update n8n when convenient.
Data as of 28 Oct 2026, 22:27 UTC
- Affects
- n8n before 1.123.85
- Patch
- Available – fixed in 2.44.1, 2.43.5, 1.123.85
CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:H/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade n8n-io/n8n to 2.44.1, 2.43.5 or 1.123.85.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubn8n-io/n8npkg:github/n8n-io/n8nOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in n8n versions 1.123.85, 2.43.5, and 2.44.1. Users should upgrade to these or later versions to remediate the credential guard bypass vulnerability. No vendor advisory content was provided to indicate alternative mitigations or temporary workarounds.
Description
A credential guard bypass vulnerability exists in n8n versions before 1.123.85, 2.43.5, and 2.44.1. This flaw allows editors of shared workflows to exploit the Execute Sub-workflow node by loading sub-workflows from URLs or local files, thereby accessing restricted credentials and obtaining their decrypted values.