CVE-2026-118640: n8n · Incorrect Authorization
Affects n8nSource CVE Database V5
Not known to be exploited · CVSS 5.3 Medium : upgrade to 1.123.85 when convenient.
Data as of 28 Oct 2026, 19:27 UTC
- Patch
- Available – fixed in 1.123.85, 2.44.1, 2.43.5
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| n8n-ion8n | Affected
| Fixed in
|
| n8n-ion8n | Affected
| Fixed in
|
| n8n-ion8n | Affected
| Fixed in
|
npmn8npkg:npm/n8nOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Apply the official fixes by upgrading n8n to versions 1.123.85, 2.43.5, or 2.44.1 or later. These versions contain patches that address the authorization bypass in the Chat Hub. No additional mitigation is indicated beyond applying these updates.
Description
CVE-2026-118640 is an authorization bypass vulnerability in n8n versions before 1.123.85, 2.43.5, and 2.44.1. It affects the Chat Hub feature, allowing users with the global:chatUser role to register restricted tool types and execute sandboxed code, access permitted files, and use instance workflows, Data Tables, and agents beyond their intended permissions.