Skip to main content
CVE-2026-118648VulnerabilityPublished

n8n before 1.123.85, 2.x before 2.43.5, and 2.44.x before 2.44.1 contains a stored cross-site scripting vulnerability

Affects n8nSource GCVE Database

0
Authoritative record:CVE-2026-118648· High 8.4

Not known to be exploited · CVSS 8.4 High · fixed in 2.44.1 : patch n8n soon.

Data as of 28 Oct 2026, 22:26 UTC

CVSS 4.0 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.44.1, 2.43.5, 1.123.85
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade n8n to 2.44.1, 2.43.5 or 1.123.85.

Affected software

ProductAffectedFixed in
npmn8npkg:npm/n8nOther threatsAffected
  • <1.123.85
  • >=2.0.0 <2.43.5
  • >=2.44.0 <2.44.1
Fixed in
  • 1.123.85
  • 2.43.5
  • 2.44.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in n8n versions 1.123.85, 2.43.5, and 2.44.1 and later. Users should upgrade to these versions or later to remediate the vulnerability. Since this is a stored XSS affecting authenticated users with workflow creation privileges, restricting such privileges to trusted users can reduce risk until patched.

Description

n8n versions before 1.123.85, 2.x before 2.43.5, and 2.44.x before 2.44.1 contain a stored cross-site scripting (XSS) vulnerability. This occurs because certain webhook response paths, including error responses and responses without headers, do not include the sandbox Content-Security-Policy header. Authenticated users with permissions to create and activate workflows can exploit this to serve malicious HTML that executes scripts in the context of the n8n origin, potentially hijacking user sessions.

References

Community reviews

Loading reviews…