CVE-2026-118648: n8n · Cross-site Scripting
Affects n8nSource CVE Database V5
Not known to be exploited · CVSS 8.4 High : upgrade to 1.123.85 soon.
Data as of 28 Oct 2026, 19:27 UTC
- Patch
- Available – fixed in 1.123.85, 2.44.1, 2.43.5
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| n8n-ion8n | Affected
| Fixed in
|
| n8n-ion8n | Affected
| Fixed in
|
| n8n-ion8n | Affected
| Fixed in
|
npmn8npkg:npm/n8nOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade n8n to version 1.123.85, 2.43.5, or 2.44.1 or later, where this vulnerability is fixed. No other mitigation is specified or required as the fix addresses the root cause by ensuring proper Content-Security-Policy headers are applied.
Description
n8n versions before 1.123.85, 2.x before 2.43.5, and 2.44.x before 2.44.1 contain a stored cross-site scripting (XSS) vulnerability. This occurs because certain webhook response paths omit the sandbox Content-Security-Policy header, allowing authenticated users who can create and activate workflows to serve malicious HTML. This HTML executes scripts in the context of the n8n origin, potentially hijacking sessions of users who open the webhook URL.