Skip to main content
VulnerabilityPublished Updated

CVE-2026-67324: Nbdime · GitPython unsafe clone option gate bypass through joined short options

Affects nbdimeSource GCVE Database

0
Authoritative record:CVE-2026-67324· Critical 9.3

Not known to be exploited · CVSS 9.3 Critical : upgrade to 4.0.4_4 as a priority.

Data as of 26 Oct 2026, 17:27 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 4.0.4_4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade nbdime to 4.0.4_4.

Affected software

ProductAffectedFixed in
Homebrewnbdimepkg:brew/nbdimeOther threatsAffected
  • >=4.0.4_3 <4.0.4_4
Fixed in
  • 4.0.4_4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in GitPython version 4.0.4_4 that fixes this issue by correctly parsing and canonicalizing joined short options before checking them against the unsafe option set. Users should upgrade to version 4.0.4_4 or later to remediate this vulnerability. Until patched, avoid passing untrusted input to the multi_options parameter or explicitly set allow_unsafe_options=True only when safe. The vendor advisory recommends recognizing joined short options such as '-uVALUE' and '-cKEY=VALUE' as their canonical short options during validation.

Description

GitPython version 3.1.50 contains a vulnerability where the default unsafe-option gate intended to block dangerous git clone options can be bypassed using joined short-option forms such as '-u<helper>'. This allows execution of local commands via Git's upload-pack option despite the default safety settings. The issue arises because the option canonicalization does not recognize joined short options correctly, leading to a residual security bypass.

References

Community reviews

Loading reviews…