Neovim remote: setuptools has a path traversal vulnerability in PackageIndex.download that leads to Arbitrary File
Affects neovim-remoteSource GCVE Database
Public exploit available · CVSS 8.7 High : upgrade to 2.5.1_3 as a priority.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 1.5% chance of exploitation in 30 days – higher than 75% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.5.1_3
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 13 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: evidence found.
Public exploit code: GitHub proofs of concept
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), GitHub proofs of concept, the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade neovim-remote to 2.5.1_3.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewneovim-remotepkg:brew/neovim-remoteOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and the vulnerability is fixed in neovim-remote version 2.5.1_3. Users should upgrade to this version or later to remediate the issue. No additional mitigation actions are required beyond applying the official fix.
Description
A path traversal vulnerability in setuptools' PackageIndex.download function allows an attacker to write files to arbitrary filesystem locations with the permissions of the running Python process. This flaw arises due to insufficient sanitization of filenames derived from URLs, enabling os.path.join to be bypassed. The issue was fixed in setuptools version 78.1.1 (corresponding to neovim-remote version 2.5.1_3). Exploitation could lead to remote code execution depending on the context. The vulnerability affects neovim-remote versions >=2.5.1_1 and <2.5.1_3. The CVSS 4.0 score is 8.7 (high severity).
References
- github.com/pypa/setuptools/security/advisories/GHSA-5rjg-fvgr-3xxf (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2025-47273 (opens in a new tab)
- github.com/pypa/setuptools/issues/4946 (opens in a new tab)
- github.com/pypa/setuptools/commit/250a6d17978f9f6ac3ac887091f2d32886fbbb0b (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/setuptools/PYSEC-2025-49.yaml (opens in a new tab)
- github.com/pypa/setuptools (opens in a new tab)
- github.com/pypa/setuptools/blob/6ead555c5fb29bc57fe6105b1bffc163f56fd558/setuptools/package_index.py (opens in a new tab)
- lists.debian.org/debian-lts-announce/2025/05/msg00035.html (opens in a new tab)