CVE-2024-6345: Neovim remote · setuptools vulnerable to Command Injection via package URL
Affects neovim-remoteSource GCVE Database
Not known to be exploited · CVSS 8.8 High : upgrade to 2.5.1_2 soon.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 1.9% chance of exploitation in 30 days – higher than 80% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.5.1_2
CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 15 Jul 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade neovim-remote to 2.5.1_2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewneovim-remotepkg:brew/neovim-remoteOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied immediately. Upgrade setuptools to version 70.0 or later and update neovim-remote to version 2.5.1_2 or newer to remediate this vulnerability. No additional mitigations are indicated by the vendor advisory.
Description
CVE-2024-6345 is a high-severity vulnerability in the setuptools package_index module up to version 69.1.1, allowing remote code execution via malicious package URLs. This flaw enables arbitrary command execution if user-controlled URLs are processed by the download functions. The issue is fixed in setuptools version 70.0. The neovim-remote product versions >=2.5.1_1 and <2.5.1_2 are affected and a patch is available in 2.5.1_2.
References
- nvd.nist.gov/vuln/detail/CVE-2024-6345 (opens in a new tab)
- github.com/pypa/setuptools/pull/4332 (opens in a new tab)
- github.com/pypa/setuptools/commit/88807c7062788254f654ea8c03427adc859321f0 (opens in a new tab)
- github.com/pypa/setuptools (opens in a new tab)
- huntr.com/bounties/d6362117-ad57-4e83-951f-b8141c6e7ca5 (opens in a new tab)
- lists.debian.org/debian-lts-announce/2024/09/msg00018.html (opens in a new tab)