Skip to main content
VulnerabilityPublished

neovim-remote · setuptools: Windows path escape via namespace_packages.txt during legacy wheel installation Description

Affects neovim-remoteSource GCVE Database

0

CVSS 1.0 Low : upgrade to 2.5.1_6 when convenient.

Data as of 29 Oct 2026, 19:00 UTC

CVSS 4.0 base score
1.0Low
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.5.1_6
CVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:A/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N

What to do

Upgrade neovim-remote to 2.5.1_6.

Affected software

ProductAffectedFixed in
Homebrewneovim-remotepkg:brew/neovim-remoteOther threatsAffected
  • >=2.5.1_1 <2.5.1_6
Fixed in
  • 2.5.1_6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in version 2.5.1_6 of the affected product. Users should upgrade to this fixed version to remediate the vulnerability. No additional mitigation steps are required once the patch is applied.

Description

A vulnerability in setuptools on Windows allows an attacker to craft a wheel file with a malicious namespace_packages.txt that causes setuptools' legacy wheel installation to create an __init__.py file outside the intended installation directory. This file has fixed content and is created with the permissions of the installing process. The issue arises because an absolute Windows path in namespace_packages.txt bypasses normal path validation during installation.

References

Community reviews

Loading reviews…