Skip to main content
VulnerabilityPublished

LRU cache · Netfoil Has a Resource Leak

Affects github.com/tinfoil-factory/netfoilSource GCVE Database

0

CVSS 5.1 Medium : upgrade to 0.3.0 when convenient.

Data as of 8 Jul 2026, 13:46 UTC

CVSS 4.0 base score
5.1Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.3.0
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:U

What to do

Upgrade github.com/tinfoil-factory/netfoil to 0.3.0.

Affected software

ProductAffectedFixed in
Gogithub.com/tinfoil-factory/netfoilAffected
  • <0.3.0
Fixed in
  • 0.3.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, monitoring memory usage and adjusting systemd service limits or restarting the service proactively may help mitigate service disruptions.

Description

A resource leak vulnerability exists in the LRU cache implementation of netfoil before version 0.3.0. When entries are removed from the cache, pointers to those elements are not properly cleaned up, causing increased memory usage. This issue can be triggered by a local attacker, potentially causing the netfoil service to consume more memory than intended. By default, systemd limits this memory usage to 100MB, which would lead to service restarts once reached. The vulnerability is classified as low severity.

References

Community reviews

Loading reviews…