Skip to main content
CVE-2026-120434VulnerabilityPublished

Netpbm before 10.86.51, 11.x before 11.02.30, and 11.03 before 11.15.08 contains a stack-based buffer overflow in

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-120434· High 8.5

Not known to be exploited · CVSS 8.5 High · fixed in 11.15.08 : patch Netpbm soon.

Data as of 2 Nov 2026, 16:57 UTC

CVSS 4.0 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.5
CNA (VulnCheck)CVSS 3.17.8
Patch
Available – fixed in 11.15.08, 11.02.30, 10.86.51
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade Netpbm to 11.15.08, 11.02.30 or 10.86.51.

Affected software

ProductAffectedFixed in
NetpbmNetpbmAffected
  • >=11.03 <11.15.08
Fixed in
  • 11.15.08
NetpbmNetpbmAffected
  • >=11.0 <11.02.30
Fixed in
  • 11.02.30
NetpbmNetpbmAffected
  • <10.86.51
Fixed in
  • 10.86.51

AI-suggested

No explicit patch links or vendor advisory content are provided in the data. However, the description identifies fixed versions: 10.86.51, 11.02.30, and 11.15.08 or later. Users should upgrade to at least these versions to remediate the vulnerability. Patch status is confirmed by the presence of fixed versions. Until upgrading, avoid processing untrusted PICT files with picttoppm.

Description

Netpbm versions before 10.86.51, 11.x before 11.02.30, and 11.03 before 11.15.08 contain a stack-based buffer overflow vulnerability in the picttoppm utility's scanPoly() function. This flaw occurs when processing crafted PICT files with polygon edges exceeding 5000 points, leading to overflow of the coord stack array. Exploitation can cause a crash or potentially allow code execution.

References

Community reviews

Loading reviews…