Skip to main content
VulnerabilityPublished

CVE-2026-15176: nginx security update

Affects nginxSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-15176· High 8.1

Not known to be exploited · CVSS 8.1 High : upgrade to 1.24.0-15.oe2403sp3 soon.

Data as of 29 Oct 2026, 11:17 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 57% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.24.0-15.oe2403sp3
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade nginx to 1.24.0-15.oe2403sp3.

Affected software

ProductAffectedFixed in
openEuler 24.03-LTS-SP3nginxpkg:rpm/openEuler/nginx&distro=openEuler-24.03-LTS-SP3Other threatsAffected
  • <1.24.0-15.oe2403sp3
Fixed in
  • 1.24.0-15.oe2403sp3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update is available in NGINX version 1.24.0-15.oe2403sp3 that addresses these vulnerabilities. Users should upgrade to this fixed version to remediate the issues. No additional mitigation actions are indicated by the vendor advisory. Systems with ASLR enabled have reduced risk of code execution, but patching remains essential.

Description

Multiple vulnerabilities have been identified in NGINX Plus and NGINX Open Source affecting versions prior to 1.24.0-15.oe2403sp3. These include heap buffer overflows triggered by specific configurations involving the alias directive with rewrite and set/return directives referencing $request_filename, or map directives using regex capture variables. Another vulnerability involves a use-after-free condition when asynchronous file I/O is enabled with Server Side Includes. Additionally, a flaw in SSL session ticket key rotation can allow forging of client SSL sessions, potentially bypassing client certificate verification. These vulnerabilities can lead to denial-of-service, memory corruption, or code execution, especially on systems without ASLR or where ASLR can be bypassed. No control plane exposure is involved; these are data plane issues only. A patch is available in version 1.24.0-15.oe2403sp3.

References

Community reviews

Loading reviews…