Skip to main content
VulnerabilityPublished

CVE-2026-15176: nginx security update

Affects nginxSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-15176· High 8.1

Not known to be exploited · CVSS 8.1 High : upgrade to 1.24.0-16.oe2403sp1 soon.

Data as of 29 Oct 2026, 11:17 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 57% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.24.0-16.oe2403sp1
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade nginx to 1.24.0-16.oe2403sp1.

Affected software

ProductAffectedFixed in
openEuler 24.03-LTS-SP1nginxpkg:rpm/openEuler/nginx&distro=openEuler-24.03-LTS-SP1Other threatsAffected
  • <1.24.0-16.oe2403sp1
Fixed in
  • 1.24.0-16.oe2403sp1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update fixing these vulnerabilities is available in NGINX version 1.24.0-16.oe2403sp1. Users should upgrade to this version or later to remediate these issues. No additional mitigations are specified by the vendor advisory. Systems with ASLR enabled have additional protection against code execution exploitation.

Description

Multiple vulnerabilities affect NGINX Plus and NGINX Open Source, including heap buffer overflows and use-after-free conditions triggered by specific configurations involving alias, rewrite, set/return directives, map regex matching, asynchronous file I/O with SSI, and SSL session cache settings. These vulnerabilities can lead to denial-of-service (DoS), memory corruption, or potential remote code execution, especially on systems without ASLR or where ASLR is bypassed. Additionally, a flaw in SSL session ticket key rotation can allow forging of client SSL sessions, potentially bypassing client certificate verification. These issues do not affect the control plane but impact the data plane. Fixed versions are available.

References

Community reviews

Loading reviews…