Skip to main content
VulnerabilityPublished

CVE-2026-15176: nginx security update

Affects nginxSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-15176· High 8.1

Not known to be exploited · CVSS 8.1 High : upgrade to 1.21.5-20.oe2203sp4 soon.

Data as of 29 Oct 2026, 11:17 UTC

CVSS 3.1 base score
8.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.8% chance of exploitation in 30 days – higher than 57% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.21.5-20.oe2203sp4
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 14 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade nginx to 1.21.5-20.oe2203sp4.

Affected software

ProductAffectedFixed in
openEuler 22.03-LTS-SP4nginxpkg:rpm/openEuler/nginx&distro=openEuler-22.03-LTS-SP4Other threatsAffected
  • <1.21.5-20.oe2203sp4
Fixed in
  • 1.21.5-20.oe2203sp4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A security update fixing these vulnerabilities is available in NGINX version 1.21.5-20.oe2203sp4. Users should apply this official patch to remediate the issues. No additional mitigation steps are indicated by the vendor advisory.

Description

Multiple heap buffer overflow and use-after-free vulnerabilities exist in NGINX Plus and NGINX Open Source related to specific configurations involving the alias directive with rewrite and set/return referencing $request_filename, map directives with regex capture variables, and asynchronous file I/O with Server Side Includes. These vulnerabilities can be exploited by unauthenticated attackers sending crafted HTTP requests, potentially causing denial-of-service (DoS) conditions or remote code execution on systems with ASLR disabled or bypassed. There is no control plane exposure; the issues affect only the data plane. Fixed versions are available.

References

Community reviews

Loading reviews…