Skip to main content
VulnerabilityPublished Updated

CVE-2025-23085: Node · A memory leak could occur when a remote peer abruptly closes the socket without sending a

Affects nodeSource GCVE Database

0
Compare
Authoritative record:CVE-2025-23085· Medium 5.3

Not known to be exploited · CVSS 5.3 Medium · fixed in 23.8.0 : update node when convenient.

Data as of 4 Nov 2026, 18:27 UTC

CVSS 3.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (hackerone)CVSS 3.05.3
Patch
Available – fixed in 23.8.0, 22.13.1, 20.18.2 +1
CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Feb 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade node to 23.8.0, 22.13.1, 20.18.2 or 18.20.6.

Affected software

ProductAffectedFixed in
Bitnaminodepkg:bitnami/nodeOther threatsAffected
  • <18.20.6
  • >=19.0.0 <20.18.2
  • >=21.0.0 <22.13.1
  • >=23.0.0 <23.8.0
Fixed in
  • 18.20.6
  • 20.18.2
  • 22.13.1
  • 23.8.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Node.js versions 18.20.6, 20.18.2, 22.13.1, and 23.8.0. Users should upgrade to these or later versions to remediate the memory leak vulnerability.

Description

A memory leak vulnerability exists in Node.js HTTP/2 server implementations when a remote peer abruptly closes the socket without sending a GOAWAY notification or when an invalid header causes connection termination. This flaw affects Node.js versions prior to 18.20.6, 20.18.2, 22.13.1, and 23.8.0 and can lead to increased memory consumption and potential denial of service.

References

Community reviews

Loading reviews…