CVE-2026-118258: Node i18next http backend · i18next-http-backend is a backend layer for i18next that loads
Affects node-i18next-http-backendSource GCVE Database
Mentioned vulnerabilities
Not known to be exploited · CVSS 3.7 Low · fixed in 4.0.4 : update node-i18next-http-backend when convenient.
Data as of 5 Nov 2026, 12:35 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 3.7 |
|---|
- Patch
- Available – fixed in 4.0.4
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 28 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10node-i18next-http-backendpkg:deb/ubuntu/node-i18next-http-backend?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSnode-i18next-http-backendpkg:deb/ubuntu/node-i18next-http-backend?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSnode-i18next-http-backendpkg:deb/ubuntu/node-i18next-http-backend?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSnode-i18next-http-backendpkg:deb/ubuntu/node-i18next-http-backend?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
i18next-http-backend is a backend layer for i18next that loads translation resources in Node.js, browsers, and Deno. Prior to 4.0.4, interpolateUrl inserts unencoded language and namespace values into loadPath or addPath templates without rejecting ampersand (&), equals (=), or semicolon (;) query separators. When a template places lng or ns in the query string and an attacker controls that value, the attacker can add or override parameters on browser or server-side translation requests, potentially exposing other namespaces or tenants or changing backend behavior through the application's network position and credentials. This vulnerability is the result of an incomplete fix for CVE-2026-41691. This issue is fixed in version 4.0.4.
References
- ubuntu.com/security/CVE-2026-118258 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-118258 (opens in a new tab)
- github.com/i18next/i18next-http-backend/commit/b0eef9efd425055c554787cef7f878de33bbf510 (opens in a new tab)
- github.com/i18next/i18next-http-backend/releases/tag/v4.0.4 (opens in a new tab)
- github.com/i18next/i18next-http-backend/security/advisories/GHSA-3cmx-xjww-583x (opens in a new tab)