Skip to main content
VulnerabilityPublished Updated

CVE-2025-15104: Nu Html Checker (vnu) contains a Server-Side Request Forgery (SSRF) vulnerability

Affects vnuSource GCVE Database

0
Compare

Public exploit available · CVSS 6.9 Medium : upgrade to 26.8.6 as a priority.

Data as of 2 Nov 2026, 22:57 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 40% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 26.8.6
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:N/SC:L/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.

What to do

Upgrade vnu to 26.8.6.

Affected software

ProductAffectedFixed in
Homebrewvnupkg:brew/vnuOther threatsAffected
  • <26.8.6
Fixed in
  • 26.8.6

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and should be applied to update Nu Html Checker (vnu) to version 26.8.6 or later. Applying this official fix will remediate the SSRF vulnerability. No additional mitigation steps are indicated by the vendor advisory.

Description

Nu Html Checker (vnu) versions prior to 26.8.6 contain a Server-Side Request Forgery (SSRF) vulnerability. This flaw allows remote attackers to bypass hostname-based restrictions and make the server perform arbitrary HTTP/HTTPS requests to internal resources, including localhost. The vulnerability is due to the ability to bypass protections using DNS rebinding or domains resolving to loopback addresses. A patch is available to fix this issue.

References

Community reviews

Loading reviews…