Skip to main content
VulnerabilityPublished

CVE-2025-52662: Nuxt DevTools vulnerable to cross-site scripting (XSS)

Affects @nuxt/devtoolsSource GCVE Database

0
Compare
Authoritative record:CVE-2025-52662· Medium 6.9

Not known to be exploited · CVSS 6.9 Medium : upgrade to 2.6.4 when convenient.

Data as of 4 Nov 2026, 17:16 UTC

CVSS 3.1 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.6.4
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Nov 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade @nuxt/devtools to 2.6.4.

Affected software

ProductAffectedFixed in
npm@nuxt/devtoolsAffected
  • <2.6.4
Fixed in
  • 2.6.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

A vulnerability in Nuxt DevTools has been fixed in version **2.6.4***. This issue may have allowed Nuxt auth token extraction via XSS under certain configurations. All users are encouraged to upgrade.

References

Community reviews

Loading reviews…