Skip to main content
CVE-2026-118669VulnerabilityPublished

prowler · OAuthLib: Token grants can use attacker-supplied client_id for authorization after authenticating a different client

Affects prowlerSource GCVE Database

0
Compare
Authoritative record:CVE-2026-118669· High 8.4

Not known to be exploited · CVSS 8.4 High : upgrade to 5.43.0_2 soon.

Data as of 31 Oct 2026, 16:36 UTC

CVSS 4.0 base score
8.4High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (GitHub_M)CVSS 4.08.4
Patch
Available – fixed in 5.43.0_2
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:H/VA:N/SC:H/SI:H/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 28 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade prowler to 5.43.0_2.

Affected software

ProductAffectedFixed in
Homebrewprowlerpkg:brew/prowlerOther threatsAffected
  • >=3.0.1 <5.43.0_2
Fixed in
  • 5.43.0_2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in OAuthlib version 5.43.0_2. Users should upgrade to this version or later to resolve the vulnerability. Until upgraded, applications should verify that their RequestValidator implementations do not authorize based solely on the client_id argument passed by OAuthlib, and instead rely on the authenticated client object to prevent this attack.

Description

OAuthlib contains a vulnerability in its token grant handlers where an authenticated low-privilege client can supply a different client_id in the token request body, causing authorization checks to be performed under that other client's identity. This affects the client_credentials and Resource Owner Password Credentials grant flows. The issue arises because OAuthlib does not require the client_id in the request body to match the authenticated client's client_id before validating grant types and scopes. As a result, a low-privilege client can obtain tokens with scopes or grant types assigned to a higher-privilege client if the application validator authorizes based on the attacker-supplied client_id argument. The vulnerability is fixed in OAuthlib version 5.43.0_2.

References

Community reviews

Loading reviews…