Skip to main content
VulnerabilityPublished

Open WebUI has a CORS misconfiguration and session validation issue

Affects open-webuiSource GCVE Database

0

CVSS 8.3 High : upgrade to 0.3.33 soon.

Data as of 27 Oct 2026, 00:58 UTC

CVSS 3.1 base score
8.3High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.3.33
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:H

What to do

Upgrade open-webui to 0.3.33.

Affected software

ProductAffectedFixed in
PyPIopen-webuiAffected
  • <0.3.33
Fixed in
  • 0.3.33

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available in Open WebUI version 0.3.33 that addresses this vulnerability. Users should upgrade to version 0.3.33 or later. The root cause is the unsafe use of FastAPI's CORS middleware with allow_origins set to "*" and allow_credentials=True. Mitigation includes removing the broad origin allowance and configuring allowed origins explicitly via administration or configuration files. Avoid using wildcard origins such as "*" or "*.com" to prevent authenticated cross-site requests.

Description

Open WebUI version prior to 0.3.33 contains a CORS misconfiguration and session validation issue that allows arbitrary websites to make authenticated cross-site requests. This vulnerability enables attackers to perform a one-click attack resulting in remote code execution on the Open WebUI instance, which runs as root in the default Docker container setup, leading to full container compromise.

References

Community reviews

Loading reviews…