Skip to main content
VulnerabilityPublished

CVE-2026-26193: Open WebUI vulnerable to Stored XSS via iFrame embeds in response messages

Affects open-webuiSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.3 High : upgrade to 0.6.44 soon.

Data as of 30 Oct 2026, 06:59 UTC

CVSS 3.1 base score
7.3High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.6.44
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 7 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade open-webui to 0.6.44.

Affected software

ProductAffectedFixed in
PyPIopen-webuiAffected
  • <0.6.44
Fixed in
  • 0.6.44

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

If you cannot patch yet, avoid manually modifying chat history or injecting embeds in response messages. Restrict user permissions to prevent unauthorized modification of chat data.

Description

Open WebUI versions prior to 0.6.44 are vulnerable to a stored cross-site scripting (XSS) issue via user-controlled iFrame embeds in response messages. The vulnerability arises because the application allows manual modification of chat history to set the embeds property, which is rendered inside an iFrames with a sandbox that improperly enables allow-scripts and allow-same-origin, effectively disabling sandbox protections. This flaw enables attackers to create weaponized chats that execute arbitrary JavaScript in the context of other users' sessions, potentially leading to session token theft and further exploitation. The vulnerability also affects shared chat links, allowing distribution of malicious payloads to other users.

References

Community reviews

Loading reviews…