OpenAM before 16.1.4 fails to enforce the Valid Creation Attributes list during self-registration, allowing anonymous
Source GCVE Database
Not known to be exploited · CVSS 9.3 Critical : upgrade to 16.1.4 as a priority.
Data as of 8 Nov 2026, 06:47 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 9.3 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 9.8 |
- Patch
- Available – fixed in 16.1.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 8 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.
What to do
Upgrade OpenAM to 16.1.4.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| OpenIdentityPlatformOpenAM | Affected
| Fixed in
|
MavenOpenAMpkg:maven/OpenAMOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, restrict or disable self-registration features if possible and monitor for unusual administrative group memberships. Avoid relying on the legacy self-service REST endpoint for user registration.
Description
OpenAM versions prior to 16.1.4 contain a critical vulnerability where the Valid Creation Attributes list is not enforced during self-registration. This flaw allows anonymous attackers to set restricted attributes, including group membership, enabling them to join administrative groups and gain full administrative control of the OpenAM system.