Skip to main content
CVE-2026-123545VulnerabilityPublished

OpenAM from 14.5.1 before 16.1.4 contains a cross-site request forgery vulnerability in the OAuth 2.0 device

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-123545· High 7.1

Not known to be exploited · CVSS 7.1 High : upgrade to 16.1.4 soon.

Data as of 8 Nov 2026, 06:47 UTC

CVSS 4.0 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.07.1
CNA (VulnCheck)CVSS 3.17.1
Patch
Available – fixed in 16.1.4
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 7 Nov 2026.

What to do

Upgrade OpenAM to 16.1.4.

Affected software

ProductAffectedFixed in
OpenIdentityPlatformOpenAMAffected
  • >=14.5.1 <16.1.4
Fixed in
  • 16.1.4
MavenOpenAMpkg:maven/OpenAMOther threatsAffected
  • >=14.5.1 <16.1.4
Fixed in
  • 16.1.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in OpenAM version 16.1.4 and later. Users should upgrade to version 16.1.4 or newer to remediate this vulnerability. Since the vendor advisory or patch links are not provided, confirm patch availability from the official OpenAM sources before applying. Until patched, avoid skipping consent for implied-consent clients in the OAuth 2.0 device authorization flow or implement additional CSRF protections.

Description

OpenAM versions from 14.5.1 up to but not including 16.1.4 contain a cross-site request forgery (CSRF) vulnerability in the OAuth 2.0 device authorization flow. This flaw allows attackers to approve device codes without user consent when consent is skipped for implied-consent clients. An attacker can initiate a device authorization and trick a logged-in user into visiting a malicious page, thereby obtaining access and ID tokens to impersonate the user in API calls.

References

Community reviews

Loading reviews…