Skip to main content
VulnerabilityPublished Updated

CVE-2026-62379: OpenAM · Unauthenticated Remote Code Execution via Class.forName in AuthXMLUtils.createCustomCallback

Affects org.openidentityplatform.openam:openam-coreSource GCVE Database

0
Authoritative record:CVE-2026-62379· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical : upgrade to 16.1.2 as a priority.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.0% chance of exploitation in 30 days – higher than 64% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 16.1.2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade org.openidentityplatform.openam:openam-core to 16.1.2.

Affected software

ProductAffectedFixed in
Mavenorg.openidentityplatform.openam:openam-coreAffected
  • <16.1.2
Fixed in
  • 16.1.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

Description

## Summary A pre-authentication remote code execution vulnerability affects OpenAM. The remote authentication endpoint (`/authservice`, PLL) accepts an XML element that names an arbitrary Java class, which the server then loads and instantiates without validation. On a default configuration this is reachable **without authentication** and allows an attacker to run code on the server. ## Impact Unauthenticated remote code execution / full server compromise on any OpenAM instance with default settings. ## Affected All releases up to and including 16.1.1 (the defect predates the Open Identity Platform fork). ## Remediation Upgrade to `16.1.2`. The fix resolves the class named in a `<CustomCallback>` element without running its static initialisers and rejects it unless it implements `DSAMECallbackInterface`, and it constrains deserialisation of the serialised `Subject` value to a class allowlist. ## Interim mitigation If you cannot upgrade immediately: - **Restrict or block external network access to `/authservice`.** This is the only reliable mitigation. - Optionally, **block PLL requests carrying a `<CustomCallback className="...">` element** at the reverse proxy or WAF. That element is only produced for custom `DSAMECallbackInterface` callbacks, so most deployments never send it — confirm against your own traffic before enforcing. - **Enabling `sunRemoteAuthSecurityEnabled` does *not* mitigate this issue.** The remote-auth security token is checked in `AuthXMLHandler.processAuthXMLRequest`, which runs only after `AuthXMLRequest.parseXML` has already parsed the request and instantiated the class named in the `<CustomCallback className="...">` element. Do not rely on it as a substitute for upgrading or for network restriction. ## Credit Vulnerability discovered by Zhixi "Jace" Sun of ASM/VI at TikTok. Correction of the interim mitigation guidance contributed by @BarakSrour.

References

Community reviews

Loading reviews…