CVE-2026-2704: Openbabel · A security vulnerability has been detected in Open Babel up to 3.1.1
Affects openbabelSource GCVE Database
Public exploit available · CVSS 5.3 Medium.
Data as of 28 Oct 2026, 22:28 UTC
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N/E:PExploitation evidence
Disclosed: evidence found.
CVE published 19 Feb 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: evidence found.
CVSS exploit maturity: proof of concept public
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10openbabelpkg:deb/ubuntu/openbabel?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSopenbabelpkg:deb/ubuntu/openbabel?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 25.10openbabelpkg:deb/ubuntu/openbabel?arch=source&distro=questingOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSopenbabelpkg:deb/ubuntu/openbabel?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSopenbabelpkg:deb/ubuntu/openbabel?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu 20.04 LTSopenbabelpkg:deb/ubuntu/openbabel?arch=source&distro=focalOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
A security vulnerability has been detected in Open Babel up to 3.1.1. The affected element is the function OpenBabel::transform3d::DescribeAsString of the file src/math/transform3d.cpp of the component CIF File Handler. The manipulation leads to out-of-bounds read. It is possible to initiate the attack remotely. The exploit has been disclosed publicly and may be used. Upgrading to version 3.2.0 is sufficient to fix this issue. The identifier of the patch is e23a224b8fd9d7c2a7cde9ef4ec6afb4c05aa08a. It is suggested to install a patch to address this issue.
References
- ubuntu.com/security/CVE-2026-2704 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-2704 (opens in a new tab)
- github.com/openbabel/openbabel/issues/2848 (opens in a new tab)
- github.com/oneafter/0128/blob/main/ob1/repro.cif (opens in a new tab)
- vuldb.com (opens in a new tab)
- vuldb.com (opens in a new tab)
- vuldb.com (opens in a new tab)