Skip to main content
VulnerabilityPublished Updated

Openbabel: Duplicate Advisory: Open Babel has out-of-bounds write in MOPAC translationVectors[] (UNIT CELL TRANSLATION)

Affects openbabelSource GCVE Database

0

CVSS 9.8 Critical : upgrade to 3.2.0 as a priority.

Data as of 7 Jul 2026, 12:28 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.2.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

What to do

Upgrade openbabel to 3.2.0.

Affected software

ProductAffectedFixed in
PyPIopenbabelAffected
  • <3.2.0
Fixed in
  • 3.2.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Until then, avoid processing untrusted MOPAC files with affected versions.

Description

## Duplicate Advisory This advisory has been withdrawn because it is a duplicate of GHSA-55f6-pf8r-c2f4. This link is maintained to preserve external references. ## Original Description Multiple out-of-bounds write vulnerabilities exist in the translationVectors parsing functionality in multiple supported formats of Open Babel 3.1.1 and master commit 530dbfa3. A specially-crafted malformed file can lead to arbitrary code execution. An attacker can provide a malicious file to trigger this vulnerability.This vulnerability affects the MOPAC file format, inside the Unit Cell Translation section

References

Community reviews

Loading reviews…