Skip to main content
VulnerabilityPublished Updated

Openbabel: Duplicate Advisory: Open Babel has out-of-bounds write (overlapping memcpy) in zipstream basic_unzip_streambuf::underflow

Affects openbabelSource GCVE Database

0

CVSS 5.3 Medium : upgrade to 3.2.0 when convenient.

Data as of 30 Jun 2026, 23:42 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 3.2.0
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:L

What to do

Upgrade openbabel to 3.2.0.

Affected software

ProductAffectedFixed in
PyPIopenbabelAffected
  • <3.2.0
Fixed in
  • 3.2.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Since this advisory is a duplicate and withdrawn, refer to the original advisory for updates.

Description

A security vulnerability in Open Babel up to version 3.1.1 affects the function zlib_stream::basic_unzip_streambuf::underflow in the zipstream implementation. This vulnerability involves an out-of-bounds write caused by overlapping memcpy operations, leading to memory corruption. Exploitation requires local access. The advisory is a duplicate and has been withdrawn in favor of GHSA-8j3x-m868-cpw8.

References

Community reviews

Loading reviews…