Skip to main content
VulnerabilityPublished

OpenClaw: Bundle MCP loopback could miss its exec denylist on session spawn

Affects openclawSource GCVE Database

0

CVSS 6.9 Medium : upgrade to 2026.5.12 when convenient.

Data as of 2 Jul 2026, 23:22 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2026.5.12
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N

What to do

Upgrade openclaw to 2026.5.12.

Affected software

ProductAffectedFixed in
npmopenclawAffected
  • <2026.5.12
Fixed in
  • 2026.5.12

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Restrict bundled MCP loopback access to trusted operators until the patch is applied. Keep channel and tool allowlists narrow, avoid sharing a Gateway between mutually untrusted users, and disable the affected feature if it is not needed. Upgrade to OpenClaw version 2026.5.12 or later to apply the official fix.

Description

OpenClaw contains a vulnerability in its bundled MCP loopback feature where the execution denylist may be bypassed during session spawn. This allows a caller with access to the affected session-spawn path to start a session with broader command execution capabilities than intended. The issue affects versions prior to 2026.5.12. The vulnerability does not alter OpenClaw's trusted-operator model but could be exploited if lower-trust input reaches the vulnerable path. Mitigation involves restricting access to trusted operators and applying the patch in version 2026.5.12.

References

Community reviews

Loading reviews…