Skip to main content
VulnerabilityPublished Updated

CVE-2026-53831: OpenClaw's POSIX node system.run safe-bin allowlist could be widened by shell expansion

Affects openclawSource GCVE Database

0

Mentioned vulnerabilities

CVSS 7.1 High : upgrade to 2026.5.18 soon.

Data as of 26 Oct 2026, 15:56 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2026.5.18
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:L

What to do

Upgrade openclaw to 2026.5.18.

Affected software

ProductAffectedFixed in
npmopenclawAffected
  • <2026.5.18
Fixed in
  • 2026.5.18

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade OpenClaw to version 2026.5.18 or later, where this issue is patched. Until upgrading, avoid broad safe-bin auto-approval for commands that can read arbitrary paths. Prefer explicit approval for node commands that access local files to reduce risk.

Description

OpenClaw's POSIX node system.run safe-bin allowlist can be bypassed due to shell expansion altering command interpretation. This allows a lower-privilege operator to cause an approved safe-bin command to read unintended local files on the node. The issue affects deployments using safe-bin or allowlist auto-approval with shell-expanded arguments on POSIX nodes. It is a policy enforcement gap in argument validation, not a direct unauthenticated takeover. The vulnerability is patched in OpenClaw version 2026.5.18.

References

Community reviews

Loading reviews…