CVE-2026-53838: OpenClaw · Node pairing reconnection could confuse approval scope state
Affects openclawSource GCVE Database
Mentioned vulnerabilities
CVSS 9.8 Critical : upgrade to 2026.5.27 as a priority.
Data as of 26 Oct 2026, 15:56 UTC
- Patch
- Available – fixed in 2026.5.27
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HWhat to do
Upgrade openclaw to 2026.5.27.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| npmopenclaw | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in OpenClaw version 2026.5.27. Until upgrading, operators should revoke any unexpected node pairings and re-pair only trusted nodes. Additionally, operators should keep channel and tool allowlists narrow, avoid sharing a Gateway between mutually untrusted users, and disable the affected node pairing feature when it is not needed.
Description
A vulnerability in OpenClaw's node pairing feature allows reconnection events to confuse the approval scope state, potentially broadening node authority beyond operator intent. This affects versions prior to 2026.5.27. The issue does not alter the trusted-operator model but can impact configurations where lower-trust inputs reach the affected feature. Operators should revoke unexpected node pairings and re-pair only trusted nodes until patched. The vulnerability is rated high severity.