Skip to main content
CVE-2026-124484VulnerabilityPublished

OpenEMR before 8.4.0 contains a missing authorization vulnerability in portal onsite-document APIs that allows any

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-124484· High 8.7

Not known to be exploited · CVSS 8.7 High : upgrade to 8.4.0 soon.

Data as of 8 Nov 2026, 17:51 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.7
CNA (VulnCheck)CVSS 3.18.8
Patch
Available – fixed in 8.4.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 8 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 8 Nov 2026.

What to do

Upgrade openemr and openemr/openemr to 8.4.0.

Affected software

ProductAffectedFixed in
openemropenemrAffected
  • <8.4.0
Fixed in
  • 8.4.0
GitHubopenemr/openemrpkg:github/openemr/openemrOther threatsAffected
  • <8.4.0
Fixed in
  • 8.4.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in OpenEMR version 8.4.0. Users should upgrade to version 8.4.0 or later to remediate this vulnerability. Since this is not a cloud service, manual patching is required. No vendor advisory content was provided to indicate alternative mitigations or temporary fixes.

Description

OpenEMR versions prior to 8.4.0 have a missing authorization vulnerability in the portal onsite-document APIs. This flaw allows any authenticated core user to access, list, read, and overwrite documents belonging to other patients by omitting the patientId parameter and supplying arbitrary record IDs. The vulnerability affects patient portal documents, signatures, and template data.

References

Community reviews

Loading reviews…