Skip to main content
VulnerabilityPublished Updated

CVE-2026-41283: OpenStack Mistral through 22.0.0 allows Arbitrary Remote Code Execution when the API is exposed

Affects mistralSource GCVE Database

0
Compare
Authoritative record:CVE-2026-41283· Critical 9.9

Not known to be exploited · CVSS 9.9 Critical · fixed in 14.0.0-0ubuntu1.1 : patch mistral as a priority.

Data as of 5 Nov 2026, 00:01 UTC

CVSS 3.1 base score
9.9Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 14.0.0-0ubuntu1.1, 18.0.1-0ubuntu1.1, 21.0.0-0ubuntu1.1 +1
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Jun 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade to a fixed release listed under Affected software.

Affected software

ProductAffectedFixed in
Ubuntu 26.10mistralpkg:deb/ubuntu/mistral?arch=source&distro=stonkingOther threatsAffected
  • 22.0.0-0ubuntu1 – 23.0.0~rc1-0ubuntu1
5 affected builds
Fixed in–
Ubuntu 26.04 LTSmistralpkg:deb/ubuntu/mistral?arch=source&distro=resoluteOther threatsAffected
  • <22.0.0-0ubuntu1.1
Fixed in
  • 22.0.0-0ubuntu1.1
Ubuntu 25.10mistralpkg:deb/ubuntu/mistral?arch=source&distro=questingOther threatsAffected
  • <21.0.0-0ubuntu1.1
  • =21.0.0~rc1-0ubuntu1
Fixed in
  • 21.0.0-0ubuntu1.1
Ubuntu 24.04 LTSmistralpkg:deb/ubuntu/mistral?arch=source&distro=nobleOther threatsAffected
  • <18.0.1-0ubuntu1.1
Fixed in
  • 18.0.1-0ubuntu1.1
Ubuntu 22.04 LTSmistralpkg:deb/ubuntu/mistral?arch=source&distro=jammyOther threatsAffected
  • <14.0.0-0ubuntu1.1
Fixed in
  • 14.0.0-0ubuntu1.1
Ubuntu 20.04 LTSmistralpkg:deb/ubuntu/mistral?arch=source&distro=focalOther threatsAffected
  • 9.0.0-0ubuntu1 – 10.0.0~b3~git2020041013.a7da00d7-0ubuntu1
6 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches provided by the vendor. Fixed versions include 14.0.0-0ubuntu1.1, 18.0.1-0ubuntu1.1, 21.0.0-0ubuntu1.1, and 22.0.0-0ubuntu1.1. Refer to the Ubuntu security notice USN-8422-1 for detailed patching instructions. There are no indications that this vulnerability is mitigated by default or that no action is required.

Description

OpenStack Mistral versions up to 22.0.0 contain a critical vulnerability that allows arbitrary remote code execution if the API is exposed. This flaw involves endpoints that permit execution of arbitrary code, potentially leading to exfiltration of service credentials. The vulnerability has a CVSS score of 9.9, indicating a critical severity level. Fixed versions are available and have been released by the vendor.

References

Community reviews

Loading reviews…